Amateurfunk Forum

Fragen und Antworten zum Thema Funk
irc
Aktuelle Zeit: Mo 21.5.2018 19:51

Alle Zeiten sind UTC + 1 Stunde




Ein neues Thema erstellen Auf das Thema antworten  [ 23 Beiträge ]  Gehe zu Seite Vorherige  1, 2
Autor Nachricht
BeitragVerfasst: Mo 2.4.2018 12:56 
Offline
S8
S8

Registriert: So 5.4.2015 14:35
Beiträge: 3453
DL1SMF hat geschrieben:

Die Frequenz dessen, was als demoduliertes Signal aus dem Lautsprecher quilt, stimmt damit nachweisbar mindestens bis auf's Hz genau mit dem über das Display eingestellten Erwartungswert überein. Das reicht mir persönlich für einen KW-TRX völlig aus.

Was damit natürlich nicht nachgewiesen ist, ist dass der LO2 (oder ein anderer in der Kiste) nicht daneben hängt. Was ich inzwischen vermute.


Genau das ist hier der Fall wenn die Empfangsfrequenz stimmt.
Die IF-Shift Frequenzen werden separat von den BFO Frequenzen abgeglichen, nämlich um die Größe der niedrigeren ZF höher als die BFO Frequenzen.


Nach oben
 Profil  
 
BeitragVerfasst: Mo 2.4.2018 13:01 
Offline
S8
S8
Benutzeravatar

Registriert: Mo 19.6.2006 18:17
Beiträge: 757
Wohnort: Altenburg JO60FX
Hallo Stefan,

ja, so habe ich das früher auch gemacht, funktioniert recht gut, wobei ich einen DCF77 dispziplinierten ocxo einsetzte, "nur" per Sekundentakt ist zu ungenau, Thema Jitter.


Ich habe nicht gemeint, das es einen Versatz zwischen RX/TX gibt, das ist recht unwahrscheinlich, das das TRXprinzip das nahezu auschliesst, außer XIT/RIT ist aktiv


ja, Prüf mal die ZF Frequenzen, denke da liegt das Problem

_________________
73´René


Nach oben
 Profil  
 
BeitragVerfasst: Mo 2.4.2018 20:52 
Offline
S8
S8

Registriert: Do 13.9.2007 20:18
Beiträge: 3753
Wohnort: Elmshorn
DC4LO hat geschrieben:
Hallo Stefan,
wenn man den BFO um nur 75Hz genau in die Mitte verstellt, sollte das Problem behoben sein.

73
Gerhard


Das war kein Aprilscherz! Bitte bedenke zum LSB/USB, das der Träger zugeführt werden BFO/Produkt-Detektor zur Demodulation... .

Die Möglichkeiten sind:

1. wir haben Quarze wie früher eingebaut, dann muss man die Frequenz vom Seitenband am Trimmer justieren

2. wir haben Möglichkeiten, so etwas in einem Setup-Menü einzustellen

3. wir haben ein modernes Gerät mit einem TCXO. In diesem Fall werden meist die VFO-Frequenzen auf die richtige Frequenz umgeschaltet, die dann möglicherweise nicht mittig durch das Quarzfilter passt. Da in diesem Fall dann alles verkoppelt ist, muss man den TCXO nachstellen. Die Frequenzanzeige des TRX wird vom Mikrocontroller angezeigt und entspricht nur der gewollten Frequenz-Einstellung. Das ist kein Frequenzzähler.

4. bei einem TS-480HX entsteht innen sehr viel Hitze, die für eine Alterung der Bauteile sorgt.

73
Gerhard


Nach oben
 Profil  
 
BeitragVerfasst: Mo 2.4.2018 21:11 
Offline
S8
S8

Registriert: So 1.10.2006 14:03
Beiträge: 511
Wohnort: Hannover
Ich kenne das Gerät nicht, hatte aber gestern mal kurz im Netz ins Service-Manual gesehen, und danach ist da ein justierbarer Quarz-Oszillator oder (optional) ein TCXO auf 15.6 MHz (Seite 150).
Da ich aber nicht weiß, was in dem obigen Bild wirklich angezeigt wird, hatte ich mich nicht geäußert. Aber vielleicht hilft es ja, da mal dran zu drehen. Schaden kann's ja nicht...

73
Werner


Nach oben
 Profil  
 
BeitragVerfasst: Mo 2.4.2018 22:58 
Offline
S8
S8

Registriert: So 5.4.2015 14:35
Beiträge: 3453
DC4LO hat geschrieben:
DC4LO hat geschrieben:
Hallo Stefan,
wenn man den BFO um nur 75Hz genau in die Mitte verstellt, sollte das Problem behoben sein.

73
Gerhard


Das war kein Aprilscherz! Bitte bedenke zum LSB/USB, das der Träger zugeführt werden BFO/Produkt-Detektor zur Demodulation... .

Die Möglichkeiten sind:

1. wir haben Quarze wie früher eingebaut, dann muss man die Frequenz vom Seitenband am Trimmer justieren

2. wir haben Möglichkeiten, so etwas in einem Setup-Menü einzustellen

3. wir haben ein modernes Gerät mit einem TCXO. In diesem Fall werden meist die VFO-Frequenzen auf die richtige Frequenz umgeschaltet, die dann möglicherweise nicht mittig durch das Quarzfilter passt. Da in diesem Fall dann alles verkoppelt ist, muss man den TCXO nachstellen. Die Frequenzanzeige des TRX wird vom Mikrocontroller angezeigt und entspricht nur der gewollten Frequenz-Einstellung. Das ist kein Frequenzzähler.

4. bei einem TS-480HX entsteht innen sehr viel Hitze, die für eine Alterung der Bauteile sorgt.


Hallo Gerhard,

Das Problem hat weder etwas mit dem Referenzoszillator noch mit dem grundsätzlichen BFO Abgleich zu tun.
Die Frequenzaufbereitung ist ja in Ordnung.
Es liegt am Oszillatorabgleich für die IF-Shift Frequenzen.


Nach oben
 Profil  
 
BeitragVerfasst: Di 3.4.2018 7:11 
Offline
S6
S6
Benutzeravatar

Registriert: Mi 1.8.2012 11:39
Beiträge: 58
Wohnort: JO31
DC4LO hat geschrieben:
DC4LO hat geschrieben:
wenn man den BFO um nur 75Hz genau in die Mitte verstellt, sollte das Problem behoben sein

Das war kein Aprilscherz!


Das hatte ich auch nicht so aufgefasst. Aber unter Umständen du? Ich bin mir immer noch nicht sicher, dass wir nicht aneinander vorbeireden...

DC4LO hat geschrieben:
Die Möglichkeiten sind:
1. [...]
2. [...]
3. wir haben ein modernes Gerät mit einem TCXO. [...]Da in diesem Fall dann alles verkoppelt ist, muss man den TCXO nachstellen.[...]


Ja, wir haben ein Gerät mit TCXO. In diesem sind aber nicht "fast alle" sondern wirklich "absolut alle" weiteren Oszillatoren mit der Master-Clock des TCXO hart synchronisiert. D.h. Ja, du kannst damit den Durchlassbereich durch das Quarzfilters anpassen. Leider dann um den Preis, dass deine TX-/RX-Frequenz daneben hängt. Diese kannst du beim TS-480 (vermutlich aus sehr gutem Grund, nämlich um genau dies Vertrimmen der Master-Clock zu dem Zweck zu verhindern) nicht separat kalibrieren. Die tatsächliche Lösung ist eine andere... siehe weiter unten in einem neuen Post in diesem "Faden"...

DC4LO hat geschrieben:
4. bei einem TS-480HX entsteht innen sehr viel Hitze, die für eine Alterung der Bauteile sorgt.


hmm,... meiner ist deutlich kälter (innen) als so manches andere und größere Gerät, welches ich hatte/kenne... und 30°C Innentemperatur halte ich jetzt nicht gerade für viel. Nach 30Min RTTY mit 50W sind es 36°C. Auch das halte ich spontan nicht für sehr viel.

vy 73,
Stefan


Nach oben
 Profil  
 
BeitragVerfasst: Di 3.4.2018 7:35 
Offline
S6
S6
Benutzeravatar

Registriert: Mi 1.8.2012 11:39
Beiträge: 58
Wohnort: JO31
Hallo...

rejection hat geschrieben:
Es liegt am Oszillatorabgleich für die IF-Shift Frequenzen.


abgesehen davon, dass wir offenbar eine sprachliche Differenz bezüglich des Begriffs "BFO" haben... LMAO ... das ist exakt der Grund (wie ich selber ja auch schon sehr früh vermutet hatte, daher ja der erste Versuch, das über die IF-Shift-Einstellung zu kompensieren)...

Was passiert da? Je nachdem, ob LSB oder USB gefordert sind, laufen die Signale frequenzrichtig oder gespiegelt durch den (bzw "die", wenn noch ein CW-Filter o.ä. eingebaut sind) Keramikfilter des TS-480. Dieser liegt vermutlich wegen Bauteiltoleranzen -- aber eigentlich ist der Grund ja auch egal -- niemals nicht wirklich super symmetrisch um seine (eigene) Centerfrequenz. Und so richtig spiegelsymmetrisch ist sein Frequenzgang meistens auch nicht...

Nutzt man nun im letzten Mischer für den LO betragsmäßig denselben Offset für LSB und USB, dann trifft man zwar exakt die rechnerische Mitte des Filters aber nur "so ungefähr" die tatsächliche. Dieser Unterschied zwischen Wunsch und Wirklichkeit lässt sich mit den Menüeinträgen #69 und #70 ("Carrier Point" USB/LSB) korrigieren. Allerdings im Falle des TS-480 nur für den Keramikfilter (den "ersten" Filter, weil der auch zum Senden benutzt wird). Alle anderen liegen (leider) so wie sie eben liegen. Da hilft nur (entweder) der DSP oder der IF-Shift-Regler.

Wer also dasselbe "Problem" (eigentlich ja eher kein technisches, sondern eines mit meinen Ohren... HI HI) hat, der drehe auf gar keinen Fall am TCXO herum! (insbesondere dann nicht, wenn derselbige nicht groß neben der Frequenz liegt und mglw. auch noch immer versiegelt ist)

vy 73,
Stefan


Nach oben
 Profil  
 
BeitragVerfasst: Di 3.4.2018 10:06 
Offline
S8
S8

Registriert: So 5.4.2015 14:35
Beiträge: 3453
DL1SMF hat geschrieben:

rejection hat geschrieben:
Es liegt am Oszillatorabgleich für die IF-Shift Frequenzen.


abgesehen davon, dass wir offenbar eine sprachliche Differenz bezüglich des Begriffs "BFO" haben... LMAO ... das ist exakt der Grund (wie ich selber ja auch schon sehr früh vermutet hatte, daher ja der erste Versuch, das über die IF-Shift-Einstellung zu kompensieren)...

Bezüglich dessen was ein BFO ist kann es keine sprachliche Differenz geben, ein BFO ist klar definiert.


Was passiert da? Je nachdem, ob LSB oder USB gefordert sind, laufen die Signale frequenzrichtig oder gespiegelt durch den (bzw "die", wenn noch ein CW-Filter o.ä. eingebaut sind) Keramikfilter des TS-480. Dieser liegt vermutlich wegen Bauteiltoleranzen -- aber eigentlich ist der Grund ja auch egal -- niemals nicht wirklich super symmetrisch um seine (eigene) Centerfrequenz. Und so richtig spiegelsymmetrisch ist sein Frequenzgang meistens auch nicht...

Nutzt man nun im letzten Mischer für den LO betragsmäßig denselben Offset für LSB und USB, dann trifft man zwar exakt die rechnerische Mitte des Filters aber nur "so ungefähr" die tatsächliche. Dieser Unterschied zwischen Wunsch und Wirklichkeit lässt sich mit den Menüeinträgen #69 und #70 ("Carrier Point" USB/LSB) korrigieren. Allerdings im Falle des TS-480 nur für den Keramikfilter (den "ersten" Filter, weil der auch zum Senden benutzt wird). Alle anderen liegen (leider) so wie sie eben liegen. Da hilft nur (entweder) der DSP oder der IF-Shift-Regler.


Auf keinen Fall laufen die SSB/CW Signale durch ein Keramikfilter, das ist ein 8-poliges Quarzfilter auf 10695 kHz.
Das Filter wird für Senden und Empfang benutzt, wird der gleiche Offset für den Carrierpunkt eingestellt müssen, Filtersymmetrie vorausgesetzt, die Frequenzverläufe in LSB und USB identisch sein.
Das sollte sich mit einem SDR Empfänger verifizieren lassen wenn der TS-480 abwechselnd in beiden Seitenbändern sendet.
Sind die Signale vom Audio Frequenzgang sendemäßig identisch, aber bei Empfang unterschiedlich, dann stimmt die IF-Shift Oszillatorfrequenz nicht.
Bei einem analogen Empfänger wird diese unabhängig von der BFO Frequenz abgeglichen und liegt um die Frequenz der dritten ZF höher als die BFO Frequenz.
Da es beim TS-480 keine dritte ZF gibt, sondern diese Funktion bereits von der DSP übernommen wird, wird vermutlich auch die IF-Shift Frequenz von dieser erzeugt.
Inwieweit sich diese Frequenz per Menü einstellen lässt weiss ich nicht, aber das müsste aus den Unterlagen bzw. den Menü Möglichkeiten hervor gehen.
Vermutlich passiert das in einem DDS Oszillator und da besteht sicher keine Möglichkeit des manuellen Abgleichs sondern nur per Software, wenn überhaupt.

Unsymmetrische Quarzfilter kommen relativ häufig vor, daher vermute ich das dort die eigentliche Ursache liegt.
Aber auch das lässt sich auch ohne SDR Empfänger herausfinden, indem man in einem QSO mal zwischen den Seitenbändern hin und her schaltet.
Wenn sich bei identisch eingestellten Carrier Abstand die Modulation unterschiedlich anhört liegt das am Quarzfilter und das wirkt sich natürlich auch bei Empfang aus.


Nach oben
 Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 23 Beiträge ]  Gehe zu Seite Vorherige  1, 2

Alle Zeiten sind UTC + 1 Stunde


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Suche nach:


Amateurfunk Elektronikforum Physik-Lab Auto Blog Elektroshop PostgreSQL Forum SEO-Blog Inline Skating